Experiences Support

Internet Explorer 11: An embedded experience does not appear as expected to users

Issue

When a user visits an embedded experience on a website using the browser Internet Explorer 11, the experience does not appear.

Technical Details

Similar errors to the ones listed below can be seen in the browser console:

Screenshot_2020-08-14_at_15.39.45.png

Cause

The issue is known to occur when the parent website hosting the experience has a META tag in the header section forcing Internet Explorer into compatibility mode. Whilst in compatibility mode the platform scripts fail to execute correctly. Here's an example of this META tag:

<meta http-equiv="X-UA-Compatible" content="IE=X"/>

The 'X' value can be any one of the following documented here. The problem is known to occur when the IE=10 (and below) value is set.

What to do

  1. Open the website featuring the embedded experience in a browser like Chrome and use the 'View Page source' option to open the HTML view of the page. The instructions here will help.
  2. Scroll to the top of the page and locate the <head> section, amongst the <meta> tags, check to see if one is listed with <meta http-equiv="X-UA-Compatible" content="IE=X"/>
  3. If you locate a this line in the <head> section, please raise this with your Web team to review this as it will need to be removed/updated before a Cheetah Experience will be correctly displayed to an IE11 visitor.